Creating Maps with QGIS
Center for Geographic Analysis, Harvard University
July 7, 2020

Exercise 1:  Map creation using QGIS software
QGIS is an open source, free, desktop geographic information software that runs on Windows, Mac, or Linux operating systems.  The goals of this exercise are:
· To use QGIS mapping software to interact with geographic data.
· To map various  school districts statistics for Louisiana.
· To merge a non-spatial table of data to a shapefile for mapping.
· To make a thematic map of schools, roads, cities and towns, and a specific demographic statistic for the New Orleans metro area. 

1. Download QGIS.  Open a web browser and go to:  https://qgis.org/en/site/forusers/download.html.  For Windows users, download the QGIS Standalone installer Version 3.14 (64 bit).
For Mac users, click MacOS and choose the QGIS macOS Installer Version 3.10 (the most stable version).  Installing on a Mac will also involve installing Python.

2. Download the data.  Download the workshop data at this URL: https:// cga-download.hmdc.harvard.edu/publish_web/GIS_Training_Workshops/Creating_Maps_With_QGIS.zip Unzip this file by double clicking on it, saving the Creating_Maps_With_QGIS folder onto your Desktop. 

3. Start QGIS.  Once installed, start QGIS by clicking Start > All Programs > QGIS 3.8 > QGIS Desktop 3.8, or on a Mac, opening the application from the Launchpad. 

[image: ]The QGIS interface has several parts to interact with, labelled on the diagram below.


Make sure the Browser and Layers panels are open.  If they are not, you can open them by clicking View > Panels and checking the box next to each of them.

4. Add a shapefile to the map.  Shapefile is a file that stores geographic data.  A shapefile actually consists of multiple files, that combine in GIS software to form one “layer” of geographic information (.shp, .shx, .dbf  are required, and sometimes a .prj and other files are also included).  Many local, state, and federal government’s make shapefiles available for anyone to download and use.  Shapefiles for this exercise were downloaded from various sources (listed below in Appendix A) and assembled into the GIS_Mapping_QGIS\Shapefiles folder. 

In QGIS, add the Louisiana School District boundaries shapefile to the map by navigating to your Creating_Maps_With_QGIS\Shapefiles folder in the Browser window, clicking on LA_School_Districts.shp, and dragging it onto the map. Also, add the LA_Municipalities.shp. You can also add these layers by going to the Data Source Manager, selecting the “Vector” tab on the left, and searching for the vector dataset in your files by clicking on the “…” button and clicking Add. You can open the Data Source Manager by clicking on this icon in the tool bar: 

[image: ]

If a window appears asking you to transform the data from the source CRS, or coordinate reference system, to WGS84/ ESPG: 4326 as the destination CRS, click Okay. ESPG: 4326 is the most commonly used CRS projection and should align any additional layers added. 

[image: ]Now that you have two layers on your map, familiarize yourself with functionality and practice using the map Navigation tools:

5. Change the Symbology of the Districts.  To change the color representing the districts, double click the LA_School_Districts layer to open the Layer Properties window and choose the Symbology tab.  Click on Simple Fill.  Now you can choose a different color for both the fill and outline of this polygon layer.

6. [image: ]Identify a School District or Municipality.  In the Layers Panel, click on LA_School_Districts layer to highlight it in blue.  Then click the Identify tool:).


Now, click on any district on the map, and a pop-up window (or a panel by the Layers panel) will display the attribute information for that district.  To Identify a municipality, highlight the LA_Municipalities layer, and then click on a municipality. To return to the normal cursor from the Identify Features cursor, click on the Pan Map symbol on the tool bar. 

7. Open a layer attribute table.  To see the entire table of attributes for a layer, right click the layer in the list of layers in the Layer panelist and choose Open Attribute Table.  Do this for the LA_Municipalities.  Look to the top of the attribute table window to see how any municipalities are in this list and scroll from left to right to see all the attributes available in the dataset.

Save your work.  Click Project > Save and save this project into your GIS_Mapping_QGIS folder as a QGZ file (.qgz), which is a QGIS project file, naming it “Louisiana Districts Map”. You will be able to open this .qgz file in the future to access the shapefiles you have added and edited. 

8. These District boundaries were downloaded from the U.S. Census and don’t have many attributes describing each district that would be helpful to us (like total schools, total enrollment, economically disadvantaged students, etc.).  The Louisiana Department of Education has many such statistics published in the form of Excel spreadsheets.  Creating a map that displays total enrollment per district, for example, could be really useful.  This is common conundrum encountered when doing GIS mapping:  The boundary shapefiles don’t include the information that are interesting to map.  A common solution employed is to do a “table join”, where data from an Excel spreadsheet, .csv, or .txt file is linked, or joined, to a GIS table.  This join, which can be done in QGIS, allows one to map the attributes in an auxiliary data file. 

9. Add the Education Department spreadsheet to the map.  In your Creating_Maps_With_QGIS folder there is a spread sheet (.xls) and csv file named “oct_2019_multi_stats”. Click on the Excel spread sheet to view the data. The .csv file, which stands for comma separated values, is the same data as the third sheet of the Excel but in a form that QGIS can read. CSV data is an unformatted text file that represents data in a spreadsheet form. These files can be opened in Excel for viewing and are the preferred format for tabular data in QGIS. Along with the .csv file there is a .csvt file, which is a template file for a .csv and provides information to maintain the field type of each column. For this exercise, maintaining the field type (double, integer, character, etc.) is important because numeric data should be recognized as numeric in order to be mapped as a continuous variable. 

Import the Education Department data by opening the Data Source Manager as you did to add the shapefiles above. Then, go to the Delimited Text tab on the left side of the window. Search for the .csv file name by clicking on the “…” button. Select CSV as the File Format, and make sure “First record has field names” and “Detect field types” are selected. Under the Geometry Definition section, select that there is no geometry. Lastly, scroll through the Sample Data to ensure it looks accurate, and then click Add and Close. 

10. Join the Education Department spreadsheet to the Districts shapefile.  Double click the LA_School_Districts layer to open the Layer Properties window and click on the  Joins tab.  Click the green plus button on the bottom of the window  to add a join.  [image: ]

Specify oct_2019_multi_stats_as the Join Layer, CODE for the Join field, and CODE for the Target field. The CODE column is a unique ID for each district that both datasets have so data can be easily joined.  Your window should look like the one below. (Note: the QGIS windows may look slightly different depending on if you are using a PC or Mac. PC on the right, Mac on the left). Click OK to activate the join.  Open the LA_Districts  attribute table and scroll to the right and you’ll see all of the statistics from the spreadsheet.  Next you’ll symbolize the map by the  % economically [image: ][image: ]disadvantaged statistic using the newly joined LA_School_Districts dataset.

11. [bookmark: _GoBack][image: ][image: ]Make a thematic map of % economically disadvantaged.  Double click the LA_Districts layer, and click the Symbology tab.  At the top, click on Single Symbol and change it to Graduated.  For the Column, choose the oct_2019_multi_stats School_system_for_gis_PCT_EC_DIS.  Click the dropdown arrow next to “Mode” and choose Natural Breaks (Jenks) as the data classification mode and click the Classify button.  Your screen should look like the below (Note: PC on the left, Mac on the right).  Click OK, and your map will now be symbolized by % economically disadvantaged for each district.  To zoom to the full extent of Louisiana, right click LA_Districts and choose Zoom to Layer.   Your map should look like the one on the page below.  
[image: ]Now you can examine the geographic distribution of economically disadvantaged school districts in Louisiana.  Experiment by shading the map by different statistics to see the geographic distribution of these.  Try different color ramps as well to see how this affects the map. 

12. Prepare to make a thematic map of New Orleans.  Add the LA_Schools, Roads, Water, and Block_Groups shapefiles to the map by clicking and dragging each shapefile from the Browser window GIS_Mapping_Workshop/Shapefiles folder to the map, or through the Data Source Manager.  Arrange your layers by dragging and dropping them within the Layer pane so that Schools are on the top, followed by Municipalities, Roads, Water, and Block Groups.  This school shapefile is a subset from a national shapefile published by the Department of Education, Education Demographic and Geographic Estimates program.  The Roads, Water, and Block Group shapefile are from the U.S. Census Bureau Cartographic Boundary shapefiles, clipped out just for the New Orleans metro area.  Right click on the Block_Groups and click Zoom to Layer to zoom into New Orleans.
 
13. Symbolize the Municipalities (A), Water(B), Roads (C), and Schools (D) layers.  Zoom in to New Orleans by right clicking the Block_Groups layer and choosing Zoom to Layer.  Turn off the LA_Districts and Block_Groups layers for now by unchecking the ✓ next to them in the Layer List.  

A) Double click the LA_Municipalities layer and choose the Symbology tab. Click Simple fill, and then the drop-down arrow next to the fill color and choose “Transparent fill”.  For the outline color, choose black.  Click OK, and now the municipalities should be displayed with just a black outline.
B)  Double click the Water layer and choose the Styles tab. Click Simple fill and choose light blue as the fill color.  For the Stroke color, choose Transparent stroke.  Click OK. 
C) Double click the Roads layer, click Simple Line, and change the color to light gray, and the stroke width of 0.1.  
D) Double click the LA_Schools layer and select Simple Marker. Change the Fill and Stroke color to black and choose a size of 1.2. and click OK.  The schools should now appear as black dots.

14. Add Municipality names to the map.  This map would be more informative if municipal labels were displayed.  To do this, double click the LA_Municipalities layer, and choose the Labels tab.  At the top, click No Labels, and change it to Single labels.  Next to “Label with”, choose the NAME field.  Click Apply, and now the municipal names will appear on your map.

To make them more legible, add a “buffer” around each layer by clicking Buffer, and check the box next to Draw text buffer and Apply.  Your screen should look like the one below (Note: PC on the top, Mac on the bottom).  Click OK to close the window, and see the labels on your map.
[image: ][image: ]
  



[image: ]At this point your map should look similar to the one below:


15. Symbolize block groups by a statistic to create a choropleth map; Census block  group borders are determined by the U.S. Census bureau and contain an average of 1,500 people per block group.  This is the smallest geographic unit at which the Census Bureau publishes population and demographic data.  Attributes in this block group layer were compiled using Social Explorer (www.socialexplorer.com) from the U.S. Census 2014 – 2018 American Community Survey data set. 

Right click the Block_Groups layer and choose Open Attribute table to see all of the statistics in this table.  Here is a description of each:
	Field
	Description

	BG_FIPS
	The Federal Information Processing Standard (unique identifier) of the block group

	Tot_Pop
	Total Population

	Pop_Dens
	Population Density (Per Sq. Mile)

	PCTPOPGT5
	% Total Population 5 to 17 Years

	PCT_WHITE
	% Total Population: White Alone

	PCT_BLACK
	% Total Population: Black or African American Alone

	PCT_HS
	% Population 25 Years and Over: High School Graduate (Includes Equivalency)

	PCT_BACH
	% Population 25 Years and Over: Bachelor's Degree

	PCT_DROP
	% Civilian Population 16 to 19 Years: Not High School Graduate, Not Enrolled (Dropped Out)

	PCT_UNEMP
	% Civilian Population in Labor Force 16 Years and Over: Unemployed

	MHI
	Median Household Income (In 2016 Inflation Adjusted Dollars)

	PCT_HISP
	% Total Population: Hispanic or Latino

	PCT_POV
	% Families: Income in 2016 Below Poverty Level



Chose a statistic to map: To symbolize block  groups by a chosen statistic, double click the Block_Groups layer and choose the Symbology tab.  Change Single symbol to Graduated at the top.  Choose the column to the statistic you are mapping.  Change the mode to Natural Breaks (Jenks), click Classify, and Apply.  Experiment with different color ramps and choose one that effectively displays your statistic. Feel free to experiment with different Modes, and number of classes as well.
 
16. Rename your layers to more descriptive names.  You can change the names of your layers by double clicking the layer, choosing the Source tab, and typing in a new layer name. You can also right click and click Rename Layer. For example, change “LA_Municipalities” to just “Municipalities”.  Also change your Block Groups name to reflect the statistic you are mapping, for example “Population Density”.

17. Compose your final map with Print Layout.  Now that all of the layers on your map are displayed how you want them to look,  it’s time to add other necessary elements to the map like a title, scale bar, legend, and sources.  This is accomplished in QGIS’s Print Layout feature.  Click Project > New Print Layout.  Enter New Orleans Map as the title and click OK.  Print Layout acts more like a graphic editing program, allowing you to add different elements like maps, legends, text and more to your layout.  Now, moving around within the Print Layout is accomplished with the Print Layout Navigation tools (see below).  [image: ]

18.  Add your map.  Click  Add Item > Add Map, and then click and drag a box onto the map canvas.  Your map will appear in this box.  Your map is now one of the “elements” on your overall map layout.  You can resize and reposition it on the page.  Also, if the extent of the map does not show exactly what you want, click back on the QGIS map window, and zoom to the new map extent.  Then back in Print Layout, click on your map and choose the Item Properties tab on the right.  Scroll down and click the Set map extent to match main canvas button: [image: ]  Now your map in Print Layout will redraw to the new extent.  Each time you change your map extent you’ll have to click this button to update it in the Print Layout.
19. Add a legend.  Click the Add New Legend tool [image: ], (or Add Item > Add Legend) and draw a box on the map to add a Legend.  Items that appear on the legend can be removed by clicking on the Legend to activate it, and then unchecking the Auto update feature on the right, choosing an item, and then clicking the red minus button: [image: ]. Also add a title to your legend under the Main Properties section of the legend item properties tab. 
20. Add a scale bar.  Add a Scale bar with the New Scale Bar tool: [image: ] (or Add Item > Add Scale Bar) and draw a box on the map to add the Scale bar.
21. Add a title.  Add a title to the map with the Add Label tool: [image: ] tool (or Add Item > Add Label). All New Labels contain “Lorem ipsum” by default.  To change this to your map title, click Item properties on the right-hand side, and change “Lorem ipsum” to “Population density, New Orleans” (Change “Population Density” to the statistic that you mapped).  Click Font and change the font size to 25 or so.  Move the title to the top center of the layout, and expand the box to display the entire title (if needed).

22. Add a North Arrow.  Add an arrow to the map with the Add Arrow tool: [image: ] (or Add item > Add North Arrow). In the Item Properties panel, expand the Search Directories section and select the north arrow image of your liking by clicking on it. .

All of the map elements in the Print Layout can be altered/customized by clicking on the element (e.g. the Legend, Scale, Text, etc.) to select it, and altering the Item properties on the right-hand side.  
23. [image: ]Add authorship and date.  With the Add Label tool: [image: ] create a new label, and enter “Map by Your_Name, date”.   Make the font smaller and move the label to the lower right of the map layout.  Your map should now look similar to the one below, but for your specific statistic: 

24. Export your map to a PNG image.  To export your map to an image, click Layout > Export as Image.  Open the resulting image to see how it looks! This can be inserted to power point for a presentation, loaded to a website, etc.  To save your work, Click Layout > Save Project.



					End of Exercise




Appendix A: Helpful QGIS and data links, and shapefile data sources 

Helpful QGIS links, and to explore further:
· The QGIS publication “A Gentle Introduction to GIS”: http://docs.qgis.org/testing/en/docs/gentle_gis_introduction/index.html 
· The QGIS users guide: http://docs.qgis.org/testing/en/docs/user_manual/index.html 

Data sources used in exercise:
LA_School_Districts -   U.S. Census cartographic boundary shapefiles:
https://www.census.gov/geographies/mapping-files/time-series/geo/carto-boundary-file.html

LA District statistics - Louisiana Department of Education
https://www.louisianabelieves.com/resources/library/student-attributes 
Selected the spreadsheet from this page:  Oct 2019 Multi stats (Total by Site and School System)

LA_Municipalities -   U.S. Census cartographic boundary shapefiles:
  (by selecting “Place” 

LA_Schools – National Center for Education Statistics, Education Demographic and Geographic Estimates (EDGE)
https://nces.ed.gov/programs/edge/Geographic/SchoolLocations

Roads, Water, Block Groups: US Census Bureau TIGER line shapefiles:
https://www.census.gov/cgi-bin/geo/shapefiles/index.php

Block Group statistics -  Social Explorer: https://www.socialexplorer.com/ 
 
Other good sources for downloading shapefiles:
Harvard Geospatial Library:	http://hgl.harvard.edu:8080/opengeoportal/
Free GIS Data Sources: http://freegisdata.rtwilson.com/?imm_mid=0d4c1a&cmp=em-data-na-na-newsltr_20150708
Natural Earth Data: http://www.naturalearthdata.com/
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